Solución de problemas «E: No se puede localizar el paquete» Error en Ubuntu [Tutorial para principiantes]

Una de las muchas formas de instalar software en Ubuntu es utilizar el comando apt-get o apt. Se abre un terminal y se utiliza el nombre del programa para instalarlo así:

sudo apt install nombre_del_paquete

A veces, puedes encontrar un error al intentar instalar la aplicación de esta manera. El error dice:

sudo apt-get install nombre_del_paquete
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nombre_del_paquete

El error se explica por sí mismo. Tu sistema Linux no puede encontrar el paquete que estás intentando instalar. ¿Pero por qué es así? ¿Por qué no puede encontrar el paquete? Veamos algunas de las acciones que puede realizar para solucionar este problema.

Solucionar el error de localización de paquetes en Ubuntu

paquete no encontrado banner

Veamos cómo solucionar este problema paso a paso.

1. Comprueba el nombre del paquete (no, en serio)

Esto debería ser lo primero que hay que comprobar. ¿Hiciste un error en el nombre del paquete? Es decir, si estás tratando de instalar vlc y escribiste vcl, seguramente fallará. Los errores tipográficos son comunes, así que asegúrate de que no has cometido ningún error al escribir el nombre del paquete.

Además, los comandos en Linux distinguen entre mayúsculas y minúsculas. Así que asegúrese de que está escribiendo el nombre correcto del paquete. Por ejemplo, el nombre del comando debe ser vlc, no Vlc o VLC.

2. Actualiza el caché del repositorio

Si es la primera vez que usas tu sistema después de la instalación, debes ejecutar el comando de actualización:

sudo apt update

Este comando no actualizará Ubuntu inmediatamente. Recomiendo que se entienda el concepto de los repositorios de Ubuntu. Básicamente, el comando ‘apt update’ construye una caché local de paquetes disponibles.

Cuando se utiliza el comando install, el gestor de paquetes apt busca en la caché para obtener la información del paquete y la versión y luego lo descarga de sus repositorios a través de la red. Si el paquete no está en esta caché, su sistema no podrá instalarlo.

Cuando tienes un sistema Ubuntu recién instalado, la caché está vacía. Es por ello por lo que debes ejecutar el comando apt update justo después de instalar Ubuntu o cualquier otra distribución basada en Ubuntu (como Linux Mint).

Incluso si no es una instalación reciente, tu caché apt podría estar desactualizada. Siempre es una buena idea actualizarla.

3. Comprueba si el paquete está disponible para tu versión de Ubuntu

Muy bien. Has comprobado el nombre del paquete y es correcto. Ejecutas el comando de actualización para reconstruir la caché y aun así ves el error de no poder localizar el paquete.

Es posible que el paquete no esté realmente disponible. Pero estás siguiendo las instrucciones mencionadas en algún sitio web y todo el mundo parece ser capaz de instalarlo así. ¿Cuál podría ser el problema?

Puedo ver dos cosas aquí. O el paquete está disponible en el repositorio de Universe y tu sistema no lo ha habilitado o el paquete no está disponible en tu versión de Ubuntu. No te confundas. Te lo explicaré.

Primer paso, comprueba la versión de Ubuntu que estás ejecutando. Abre un terminal y utiliza el siguiente comando:

lsb_release -a

Obtendrá el número de versión de Ubuntu y el nombre del código en la salida. El nombre en clave es lo importante aquí:

$ lsb_release -a
LSB Version:	core-11.1.0ubuntu4-noarch:printing-11.1.0ubuntu4-noarch:security-11.1.0ubuntu4-noarch
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04 LTS
Release:	22.04
Codename:	jammy

Como puedes ver aquí, estoy usando Ubuntu 22.04 y su nombre en clave es jammy. Es posible que tengas otra cosa, pero tienes la esencia de lo que necesitas anotar aquí.

Una vez que tengas el número de versión y el nombre en clave, dirígete al sitio web de paquetes de Ubuntu:

Desplázate un poco hacia abajo en esta página y ve a la parte de la búsqueda. Verás un campo de palabras clave. Introduce el nombre del paquete (que no puede ser encontrado por tu sistema) y luego pon el nombre en clave de la distribución correcta. La sección debería ser «cualquiera». Cuando hayas configurado estos tres datos, pulsa el botón de búsqueda.

buscando paquetes de ubuntu
Buscando Paquetes de Ubuntu

Esto mostrará si el paquete está disponible para tu versión de Ubuntu y si es así, a qué repositorio pertenece. En mi caso, busqué la herramienta de captura de pantalla Shutter y esto es lo que me mostró para la versión Ubuntu 18.04 Bionic:

paquete encontrado

El nombre del paquete coincide exactamente. Esto significa que el paquete shutter está disponible para Ubuntu 18.04 Bionic pero en el ‘repositorio Universe’. Si te preguntas qué diablos es el repositorio Universe, por favor, consulta el artículo sobre el repositorio de Ubuntu que he mencionado antes.

Si el paquete deseado está disponible para tu versión de Ubuntu pero en un repositorio como Universo o Multiverso, debe habilitar estos repositorios adicionales:

sudo add-apt-repository universe multiverse

También debes actualizar la caché para que su sistema conozca los nuevos paquetes disponibles a través de estos repositorios:

sudo apt update

Ahora si intentas instalar el paquete, las cosas deberían ir bien.

Comprueba si estás usando una versión activa de Ubuntu

Ubuntu tiene dos tipos principales de versiones. La versión regular tiene un soporte de nueve meses mientras que las versiones de soporte a largo plazo tienen un soporte de cinco años.

En cualquier caso, si estás utilizando una versión de Ubuntu que ha llegado al final de su vida útil, no podrás instalar ningún paquete nuevo y verás este error de imposibilidad de localizar el paquete.

¿Cómo saber si tu versión de Ubuntu es compatible o no? Utiliza este sencillo comando para averiguarlo:

hwe-support-status --verbose

Para mi versión compatible, muestra esta salida:

Su Hardware Enablement Stack (HWE) es compatible hasta abril de 2027.

Puede olvidarse de la pila de habilitación de hardware por el momento. La información importante es si el sistema está soportado activamente. En el ejemplo anterior, mi sistema está soportado hasta abril de 2027.

Nada funciona, ¿ahora qué?

Si el sitio web de Ubuntu Packages también muestra que el paquete no está disponible para tu versión específica, entonces tendrás que encontrar otras formas de instalar el paquete.

Por ejemplo, Shutter. Es una excelente herramienta de captura de pantalla para Linux, pero no se ha actualizado en años y, por lo tanto, Ubuntu lo ha eliminado de Ubuntu 18.10 y las versiones más recientes. ¿Cómo instalarlo ahora? Afortunadamente, algún desarrollador de terceros creó un repositorio personal (PPA) y puedes instalarlo usando eso. [Por favor, lee esta guía detallada para entender el PPA en Ubuntu]. Puedes buscar paquetes y su PPA en el sitio web Launchpad de Ubuntu.

Ten en cuenta que no deberías añadir PPAs al azar (no oficiales) a tu lista de repositorios. Te aconsejo que te quedes con lo que te proporciona tu distribución.

Si no hay PPAs, comprueba el sitio web oficial del proyecto y mira si proporcionan algunas formas alternativas de instalar la aplicación. Algunos proyectos proporcionan archivos .DEB o archivos AppImage. Algunos proyectos han cambiado a paquetes Snap.

En otras palabras, compruebe el sitio web oficial del proyecto y compruebe si han cambiado su método de instalación.

Si nada funciona, tal vez el propio proyecto esté descatalogado y, si ese es el caso, deberías buscar su aplicación alternativa.

En fin…

Si eres nuevo en Ubuntu o en Linux, las cosas pueden ser abrumadoras. Es por eso por lo que estoy cubriendo algunos temas básicos como este para que usted obtenga una mejor comprensión de cómo funcionan las cosas en su sistema.

Espero que este tutorial te ayude a manejar el error de los paquetes en Ubuntu. Si tienes preguntas o sugerencias, no dudes en preguntar en la sección de comentarios.

Publicaciones Similares

Deja una respuesta

Tu dirección de correo electrónico no será publicada.